Schwachstelle im PHP Script timthumb.php

Es wurde bekannt, dass das PHP Script timthumb zum dynamischen verabreiten von Bildergrößen in Webseiten eine gefährliche Schwachstelle hat. timthumb wird in vielen WordPress Templates benutzt und daher sind viele WordPress Installationen durch diese Schwachstelle gefährdet. Webseitenbetreiber sollten schnellstmöglich Ihre Installationen auf die Verwendung des timthumb Scriptes prüfen und dieses gegebenenfalls so schnell wie möglich auf die neueste Version aktualisieren.

Kunden, die bei kn² Datentechnik ein Template mit dem timthumb Script erworben haben (z.B. von Woothemes) brauchen sich nicht zu kümmern, diese Installationene wurden alle von uns überprüft und aktualisiert. Weitere Informationen und eine Übersicht, welche Templates betroffen sind, findent man hier:

http://www.perun.net/2011/08/04/wordpress-themes-die-von-der-timthumb-sicherheitsluecke-betroffen-sind/

Die aktuelle Version von timthumb findet man hier:

http://timthumb.googlecode.com/svn/trunk/timthumb.php

 

0 Kommentare

Dein Kommentar

An Diskussion beteiligen?
Hinterlasse uns Deinen Kommentar!

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.